deadsimple BSD Security Advisories and Announcements

OpenBSD Errata: May 19th, 2017 (exec_subr)

Errata patches for exec_subr have been released for OpenBSD 6.1 and 6.0.

An additional mitigation is added by placing a gap of 1 MB between the
stack and mmap spaces.

Binary updates for the amd64 and i386 platforms are available via the
syspatch utility. Source code patches can be found on the respective
errata pages:

As this affects the kernel, a reboot will be needed after patching.